System Requirements


For the optimal TAP Series learning experience on desktop, we support the current and previous two releases of the following browsers:

Each time a new browser version is released, we begin supporting that version along with the last two supported versions.

Important: Using older browser versions can prevent you from accessing your TAP course, and some site features won't function as expected. Using the latest browsers also provides better encryption and privacy support.

Please review the current available version of your preferred browser and download the latest version to enjoy an optimal site experience.

Copyright ©2022 TAP Series, LLC